Hotspot login problem with splynx

Now all the configuration is done but any username and password from hotspot login page accepts even when is not created on the radius server or on the mikrotik and it shows on the mikrotik server as login from radius however is not and nothing is showing on the radius server that client online please what could that be??

Try to go to: Config / Networking / Radius

and than set values like on this screenshot:

after doing that RADIUS server is not responding

https://splynx.com/forum/radius-troubleshooting-ispframework-and-mikrotik/

here is information how to enable debug logs, enable please and share debug logs

the server respond now but still the same problem and username and password work even when it’s not created

so, what about logs, and debug ?

; <?php exit(); ?>
; Do not remove this lines

; Splynx radd config file
address = 127.0.0.1
port = 2412
sql_check = 300
pid_file = “/var/run/splynx_radd/splynx_radd.pid”

; rrd graphs part
[rrd]
enable = true
rrdcached = true
path = /var/www/splynx/system/rrd/db/

; debug part (please, don’t use debug in production)
[debug]
enable = true
level = 9
mem_usage = true
console = false ; useful only if you run daemon directly (not recommended)
syslog = false ; very slow
file = true ; best way
debug_file = “/var/www/splynx/logs/radius/debug.log”

[short_log]
enable = true
short_log_file = “/var/www/splynx/logs/radius/short.log”

[customer_restriction]
add_mac = true
max_mac = 3

this is not debug file, this is config file

this is debug file

you want me to send you the log print

you can read it and try to understand where is problem

Bro i just have to find different solution because i don’t know why the system accept ungenerated code and if you enter the correct code too nothing shows on control panel

that’s why we need to check you debug file :slight_smile:
may be your request from router don’t going to radius ? ) or any other problem
but without debug, about what we talking ?

12/05 18:13:56:SPLYNXRADD:[5.29 mb ]: Starting Splynx RADD daemon…
12/05 18:13:56:SPLYNXRADD:[5.3 mb ]: Loading config file radius.php…
12/05 18:13:56:SPLYNXRADD:[5.3 mb ]: Set RRDCached socket address to /var/run/rrdcached.sock
12/05 18:15:07:SPLYNXRADD:[5.88 mb ]: Client #1–Connected …

12/05 18:15:07:SPLYNXRADD:[5.99 mb ]: Client #1 Authorization
12/05 18:15:07:SPLYNXRADD:[6.01 mb ]: Start authorize
12/05 18:15:07:SPLYNXRADD:[6.01 mb ]: Connection type: ppp
12/05 18:15:07:SPLYNXRADD:[6.1 mb ]: Start authorize_other
12/05 18:15:07:SPLYNXRADD:[6.1 mb ]: Start internal_test_user
12/05 18:15:07:SPLYNXRADD:[6.1 mb ]: Return OK, system work fine
12/05 18:15:07:SPLYNXRADD:[6.11 mb ]: Client #1 Send accept…
12/05 18:16:31:SPLYNXRADD:[5.29 mb ]: Starting Splynx RADD daemon…
12/05 18:16:31:SPLYNXRADD:[5.3 mb ]: Loading config file radius.php…
12/05 18:16:31:SPLYNXRADD:[5.3 mb ]: Set RRDCached socket address to /var/run/rrdcached.sock
12/05 18:18:37:SPLYNXRADD:[5.88 mb ]: Client #1–Connected …

12/05 18:18:37:SPLYNXRADD:[5.99 mb ]: Client #1 Authorization
12/05 18:18:37:SPLYNXRADD:[6.01 mb ]: Start authorize
12/05 18:18:37:SPLYNXRADD:[6.01 mb ]: Connection type: hotspot
12/05 18:18:37:SPLYNXRADD:[6.1 mb ]: Start authorize_other
12/05 18:18:37:SPLYNXRADD:[6.39 mb ]: Login ty2mkHiK not found in customer services
12/05 18:18:37:SPLYNXRADD:[6.46 mb ]: Use reject attribute Mikrotik-Address-List = Reject_0
12/05 18:18:37:SPLYNXRADD:[6.47 mb ]: Unknown user, try to get error ip
12/05 18:18:37:SPLYNXRADD:[6.5 mb ]: Set error IP: 250.250.250.18
12/05 18:18:37:SPLYNXRADD:[6.52 mb ]: Client #1 Send accept…
12/05 18:18:37:SPLYNXRADD:[6.54 mb ]: Client #1 Accounting
12/05 18:18:37:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.18
12/05 18:18:50:SPLYNXRADD:[6.63 mb ]: Client #1 Accounting
12/05 18:18:50:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.18
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Client #1 Authorization
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Start authorize
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Connection type: hotspot
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Start authorize_other
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Login ty2mkHiK not found in customer services
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Use reject attribute Mikrotik-Address-List = Reject_0
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Unknown user, try to get error ip
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Set error IP: 250.250.250.178
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Client #1 Send accept…
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Client #1 Accounting
12/05 18:19:01:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.178
12/05 18:19:19:SPLYNXRADD:[6.63 mb ]: Client #1 Accounting
12/05 18:19:19:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.178
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Client #1 Authorization
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Start authorize
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Connection type: hotspot
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Start authorize_other
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Login jijkh not found in customer services
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Use reject attribute Mikrotik-Address-List = Reject_0
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Unknown user, try to get error ip
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Set error IP: 250.250.250.15
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Client #1 Send accept…
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Client #1 Accounting
12/05 18:19:27:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.15
12/05 18:19:30:SPLYNXRADD:[6.63 mb ]: Client #1 Accounting
12/05 18:19:30:SPLYNXRADD:[6.63 mb ]: Ignoring error IP accounting: 250.250.250.15
12/05 18:19:51:SPLYNXRADD:[6.65 mb ]: Client #1–Disconnected …

12/05 18:20:08:SPLYNXRADD:[6.57 mb ]: Client #2–Connected …

12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Client #2 Authorization
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Start authorize
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Connection type: ppp
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Start authorize_other
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Start internal_test_user
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Return OK, system work fine
12/05 18:20:08:SPLYNXRADD:[6.67 mb ]: Client #2 Send accept…
12/05 18:21:31:SPLYNXRADD:[6.57 mb ]: Current memory usage: 6,728.891K
12/05 18:21:31:SPLYNXRADD:[6.58 mb ]: Check, ok…, Config reloaded…

if we will talk about that, you looks like not save or not make any from my first topic:

the situation with hotspot:
radius with default config accept any customer, but only for correct give normal IP and address-list

https://splynx.com/2666/blocking-of-non-paying-customers/ - more information about blocking on splynx. (not for hotspot)

Obed, have you fixed it ? The only thing that you need to change is on Config -> Networking -> Radius remove all the data from Reject attributes fields and setup Use Reject IP = No.
Then Splynx will not accept non authenticated users at all.

By default we assign to users IPs from fake pools or send users to wrong address list. But this can be changed quickly in configuration, please check the screenshot on first answer of Ruslan.

We have the same issue.
I have understood that the Hotspot User can be rejected entirely by removing the Reject_IP Ranges.
Unfortunately that won’t work as in parallel used PPPoE NAS Systems on the same Spylnx Server will also be completely refused. Could we have this setting ‘per Router’ to be able to control it better?

Why not ?, but per NAS type :slight_smile:
So, add new NAS Type on Config / Networking (like Mikrotik Hotspot). and copy configuration from Mikrotik, and use it for hotspot routers.

Tried and works perfectly.
That way we can also separate Mikrotiks which are used per AAA-Queues and Mikrotiks which are used with API-Queues.

Perfect!
Thanks, Heiko

1 Like