Unmet dependencies


#1

The following issue appears when I get the point of installing the splynx platform:

The following packages have unmet dependencies:
 splynx : Depends: splynx-5.6 (>= 1.3.2643) but it is not going to be installed or
                   splynx-5.5 (>= 1.3.2643) but it is not going to be installed or
                   splynx-5.4 (>= 1.3.2643) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

the error above appears after I get to the install step using:

apt-get install splynx

Can you point to where to start to look for issue?


#2

Hi, you can try to install:

apt install splynx-5.6
apt install splynx-5.5
apt install splynx-5.4

depends on PHP version (php -v)
and then

apt install splynx


#3

hi @ex,

I discovered that I broke some mysql settings and that is the cause I can deduce so far.

the MPM manager broke some mod_sql packages I enabled when I should not have

You instructions did install some packages up to a point. So I am reimaging the server will respond so others can maybe find answers on this what I did or did not do.

regards,
Al