Splynx Network Weathermaps


#1

Hi

After installing a ssl certificate on splynx and changing over to ssl, splynx network weathermaps no longer works.
Normally the addons needs changing in the params.php file, which I did.

I change the url from http to https.

I can access the config section of network weathermaps, but cannot view network weathermaps under networking section, when I open weathermaps under networking section, I am presented with a blank page.

Please help


#2

try to:

ping ssl_host

from server, and post here result.


#3

#####@SPLYNX:~$ ping ssl_host
PING ssl_host.###.co.za (54.200.##.##) 56(84) bytes of data.

I get no replies, it shows the wrong domain name as well as the wrong public ip address.

I am a bit unfamiliar with this, how to I go about to correct this?


#4

can you try to ping your domain name ?


#5

Hi

Yes and I do get replies. The splynx portal is up and running, it is the network weathermap that is not loading.


#6

ok, what IP do you receive when ping ?

public or 127.0.0.1 ?


#7

@SPLYNX:~$ ping portal.riverbroadband.co.za
PING portal.riverbroadband.co.za (196.61.80.5) 56(84) bytes of data.
64 bytes from portal.riverbroadband.co.za (196.61.80.5): icmp_seq=1 ttl=64 time=0.433 ms
64 bytes from portal.riverbroadband.co.za (196.61.80.5): icmp_seq=2 ttl=64 time=0.390 ms
64 bytes from portal.riverbroadband.co.za (196.61.80.5): icmp_seq=3 ttl=64 time=0.459 ms

Public IP Address

In the splynx addon params.php file I have the below configured (Note that I have replaced the api_key, api_secret & cookie validationkey with “*” in this post for security purposes:

<?php return [ 'api_domain' => 'https://196.61.80.5/', 'api_key' => '*************************************', 'api_secret' => '***********************************', 'cookieValidationKey' => '**********************************' ];

#8

The first part of my splynx-ssl file in /etc/nginx/sites-enabled/ ( Note I have changed my ssl cert and key paths to “*” in this post for security purposes):

Splynx default SSL config file for Nginx

Splynx s.r.o.

http://splynx.com/

— # Please uncomment following lines when configuration will be finished (for redirect http traffic to https)

server {
listen 80;
return 301 https://$server_name$request_uri?; # enforce https
}

— # end

server {
listen 443;
server_name portal.riverbroadband.co.za;

    access_log  /var/www/splynx/logs/nginx/splynx-access.log;
    error_log   /var/www/splynx/logs/nginx/splynx-error.log;

    client_max_body_size 20m;
    client_body_timeout 300s;


    gzip            on;
    gzip_disable    "msie6";
    gzip_comp_level 6;
    gzip_min_length 1100;
    gzip_buffers    16 8k;
    gzip_proxied    any;
    gzip_types      text/plain application/xml text/css text/js text/xml application/x-javascript text/javascript application/javascript application/json application/xml+rss;

    root /var/www/splynx/web;
    index index.php;

    charset utf-8;

    ssl on;

    # this is defaults certs, please change it to real.

    # --- # Please change here for your SSL Cert

    ssl_certificate ***********;
    ssl_certificate_key *************;

If I change the URL in the google-maps addon params.php from http to https, it breaks the addon. Whereas it works when it is set to http.

If I set the splynx weathermap addon params.php to http, I get redirected to the customer portal login page when openeing the network weathermaps view page.


#9

https://www.ssllabs.com/ssltest/analyze.html?d=portal.riverbroadband.co.za

for normal work should be A, A+


#10

Hi

After correcting this, I have a A+ rating now and it is still not working.


#11

I now have network weathermaps working. :slight_smile:

But

The google maps addons says Error Auth, I did delete the config.php as perone of your other posts and reconfigured the package. therafter I added my API key into the configuration and changed the url from http to https and still get Error Auth.

Any ideas perhaps?


#12

After 4th attempt with the 4th api key from google and a full reboot, it is now working.

Thanks for your assistance :slight_smile: