Sectoes(Limits) - How to use?

Hello Team,

I haven’t entirely unterstand how to properly setup the Sectors/Limits Feature.
This Feature is a perfect for WiMAX/Radio Sector Limits which would allow us to let a parent Queue know how much total capacity a group of customers have.

Nevertheless, the Feature does not work as expected.
For example, if we create a customer and set him in a Sector, then Splynx will create a Queue on the Mikrotik but with PCQ Queueing by default (which we cannot change from Splynx it seems). This must be wrong.

Secondly, the PPPoE Login of the Customer is not set to use the Parent of this queue but continues to be without a Parent, therefore the PPPoE-Entry doesnt work anymore at all.

Third, I believe that the Parent Queue (Sp_STS_4-4) should not have a IP Address Target set as more customer would potentially use this sector - each with his own different IP

And Lastly, use of the Sector Feature seems only to work if we set Static/Permanent IP’s for each customer.


Third, I believe that the Parent Queue (Sp_STS_4-4) should not have a IP Address Target set as more customer would potentially use this sector - each with his own different IP

–> As to that point, this seems working as Splynx adds each Child IP to the Parent Queue everytime a Queue Child comes in.

As i see you want to mix static shaping (API) with dynamic (Radius) …

but this is don’t work.

sectors, like a other API features (example Aggregation) will work only with Static shaping (Mikrotik API, with assigned Router and IP)

ps: you need to disable rate limit attributes for radius in this case. (Config / Networking / Radius )

Means, I cannot use Radius/PPPoE Queues against Sectors?

I completely removed Sectors from clients - but left the Aggregation (in Tariffplan) settings.
This still leaves me with PCQ-Queues for each Child…

Furthermore, the PPPoE Entries from Radius still wont point to their “Tarif-parent”.

I think I see your Point --> Splynx cannot push a Parent Queue to the Mikrotik via AAA.
Therefore the Dynmaic PPPoE Queues wont point to the statically via API added Queues.

We still need a solution for this problem – 90% of all Users are authenticated via Radius (PPPoE or DHCP) - and we still should be possible to use the Aggregation Feature or the Sector Feature.

Any idea how this can be achieved?


Yes, authentication with radius is OK, but shaping place to static (assign IP and Router for every customer) if it’s possible …

and comment Rate-Limit Attribute on Radius config (for this NAS type)

Hi Ruslan,

thanks for that workaround - will test…

Nevertheless its a workaround…:

– Ideally we should be able to keep dynamic IP’s for customers in place as that is easiest to set up and still be able to use Aggregation and sectorization.
– Furthermore it should somehow be possible to place PPPoE Dynamic Queues below a API added Queue?
– All the API Queues are generated with ‘Pcq-default-download’ respecetive ‘pcq-upload-default’ queue type which is leaving every IP in the queue 50kbps by default… Changing the default Queue Type to 'default’
in Config seems not affecting this and the API Queues keep being pcq…
– Is there are way to manually ‘push’ the full set of API Queues to the Mikrotik (after deleting them on the Tik)? Right now I am waiting since 10min for Splynx to to push them which didnt seem to happen anymore…

Hello Ruslan,

Got it working the way I needed it - thanks for the Tips!
One more thing, I also needed to disable the Ratelimit fields for CoA - otherwise the PPPoE Dynamic Queue would pop up after some time (and on a FUP Change).

I was also able to change the Queue Type from pcq to pfifo.


about FUP - better to use like on this screenshot:

you about this ? (Config / Networking / Mikrotik API / Simple shaping )