Port ID RADIUS field mapping issue with NetElastic vBNG - Circuit ID not matching

Hello all,

We’ve been using MikroTik with Splynx for a long time now and are authenticating users based on DHCP Option 82 Circuit ID. This works great.

We have recently started investigating a new BNG platform, NetElastic vBNG, which also sends the Circuit ID, but under a different VSA. I can’t get the accounts to authenticate with the circuit ID matching Port ID.

Here is an example of the RADIUS request from a MikroTik, which works:
Attribute Value Pairs > VSA (26) Ericsson (2352) > Agent-Circuit-Id (97) > [circuit-id-string]

On vBNG, it is sent like this.:
Attribute Value Pairs > VSA (26) Broadband Forum (3561) > ADSL-Agent-Circuit-Id (1) > [circuit-id-string]

I have investigated various options in vBNG but can’t see a way to get it to change the VSA used. Is there a way to make Splynx match the Broadband Forum version?


I would also be happy to match on NAS-PORT-ID, ignoring the VSA options, if that is possible.


unfortunately we have no clients who are using this (NetElastic vBNG) so can’t advise you something to make it work at the moment. Currently we are busy with investigation of NetElastic vBNG so we will provide you the answer in a ticket.