Logs files getting bigger

Hello, recently I found out that the disc drive run out of space, I search biggest directories and realised that the files *.log are getting bigger since august, in special accounting.log, It grown up to 700 GB

I had to ereased it.

Now I see that all *.log files are not getting converted to *.gz, every 8 days.

Is this some kind of bug?, the latest update of splynx was around that date.
I would appreciate your help very much. Thanks

here you can see the biggest files.

and the example that log files are not getting converted to *.gz

Such a big files mean debug logging is enabled in Splynx.
You would better disable debug logging for everyday Splynx usage. Debugging is only needed in case of investigating issues.
Debug logging can be disabled on page Config / Networking / MikroTik API
Disable Debug
Disable Write log file for accounting

These settings will reduce output to logs. But logs are still on disk.
You can compress these files or just remove them.
Compress with:
logrotate --force /etc/logrotate.d/splynx
May be this command should be run at least two times to compress current log file.
Please note, do compression if you really need these log files. If you don not need them, please remove with rm command. Such a big files can be removed significantly faster than compressed.

Hi, Config / Networking / MikroTik API, was enabled, I disabled it.
The log file is still growing in size.
The Write log file for accounting option was already disabled. These log files where compressed automatically and ereased certain time, I think it is a cron service that stop working.