Can't install Quickbooks add on


#1

When I run apt install splynx-quickbooks the console throws this error:

chmod(’/var/www/splynx/addons/quickbooks/data’, 0777)…done.
chmod(’/var/www/splynx/addons/quickbooks/data/data.db’, 0777)…done.
PHP Fatal error: Uncaught exceptions\InvalidParam: Invalid action “add-or-get-hook”! in /var/www/splynx/app/base/Controller.php:41
Stack trace:
#0 /var/www/splynx/app/core/Router.php(256): base\Controller->runAction(‘add-or-get-hook’, Array)
#1 /var/www/splynx/app/core/Router.php(212): core\Router->runAction(Object(controllers\console\AddonController))
#2 /var/www/splynx/app/core/Router.php(171): core\Router->run()
#3 /var/www/splynx/app/ConsoleApp.php(26): core\Router->dispatchConsoleRequest(‘addon’)
#4 /var/www/splynx/system/script/addon(16): ConsoleApp->run(‘addon’)
#5 {main}
thrown in /var/www/splynx/app/base/Controller.php on line 41

And when I navigate to /admin/config/add-on?module=splynx_quickbooks_addon&point=3
It shows this error:

Error: /var/www/splynx/addons/quickbooks/config/params.php not found! You must run ./yii install!

What should I do?


#2

splynx 1.3 ?


#3

If I run

sudo apt-get install splynx

I get this:

Reading package lists… Done
Building dependency tree
Reading state information… Done
splynx is already the newest version (1.2.1064).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

How can I update to v1.3?


#4
apt update
apt dist-upgrade

#5

Version 1.3 live now


#7

Just for the record, I ran

./yii install

the file was under this directory:

/var/www/splynx/addons/quickbooks

Thank you so much!


#8

also possible to use

dpkg-reconfigure splynx-quickbooks